IFish Fishing Forum banner
1 - 13 of 13 Posts

· Registered
Joined
·
3,137 Posts
Discussion Starter · #1 ·
I'm an idiot. So, I wasn't a bit surprised when my Navman 2100 fuel flow meter did not work correctly after I installed it. I re-read the installation instructions several times and moved the transducer to every possible position I could with the same results. I even replaced all the fuel lines from the tank to the fuel pump.

I finally sent the unit to Navman and they returned it. Unfortunately, they didn't share any info on it - whether they fixed it or just tested it and found it working correctly. When I finally got through to them and explained what the meter was doing, they said there must be some air in the system.

Like I said, I'm an idiot so I just gave up on it.

But when two mechanically minded friends of mine bought the same units and got the same results, I rethunk my problem.

In each of our installations, we have the transducer installed between the fuel/water separator and the fuel pump. The transducer is mounted so that the fuel flows upward (veritcally mounted) through the transducer on its way to the fuel pump. This is how Navman instructs to install.

The only thing I can think of that may be creating the problem we all three have - fuel consumption reads at 2 to 2.5 times actual consumption - is that we all three have our kicker motors plumbed off of the fuel/water separators. Would that create a problem?

Any advice will result in three happier fishermen. :D:D:D
 

· Registered
Joined
·
479 Posts
Phil,

Do you have it set for US Gallons?

Mine came from the factory with the unit of measure as litres!!!

LA
 

· Registered
Joined
·
3,137 Posts
Discussion Starter · #4 ·
The sensor needs to be mounted horizontally and the fuel lines set to run "uphill" to your engine.

-LOL
LOL,

Admittedly, I have not tried what you are suggesting. I have had it mounted horizontally but the fuel was not running uphill to the engine.

Here's what the installation instructions say for this unit:

"The fuel flow transducer is designed for installation
in Coast Guard approved 9.5 mm
(3/8”) flexible fuel line. The transducer MUST be
installed AFTER the main fuel filter. It should be
located well away from any area where it will be
effected by excessive heat or vibration from the
engine. It is preferable to mount the transducer in a​
vertical position."

:shrug:
 

· Registered
Joined
·
479 Posts
I thought I had a gas hog on my hands!.....at that rate of consumptionI wouldn't make it past the whistle bouy!

LA
 

· Registered
Joined
·
1,525 Posts
Don't know what to tell you then. The 3200 series sensor manual, (page 25) shows and calls for horizontal mounting. I guess vertical is correct for your sensor model. Sorry, just trying to help. My Floscan requires horizontal mounting so I was going off of experience and the manual above.
Good luck!


LOL,

Admittedly, I have not tried what you are suggesting. I have had it mounted horizontally but the fuel was not running uphill to the engine.

Here's what the installation instructions say for this unit:

"The fuel flow transducer is designed for installation
in Coast Guard approved 9.5 mm
(3/8”) flexible fuel line. The transducer MUST be
installed AFTER the main fuel filter. It should be
located well away from any area where it will be
effected by excessive heat or vibration from the
engine. It is preferable to mount the transducer in a​
vertical position."

:shrug:
 

· Registered
Joined
·
442 Posts
I'm an idiot. So, I wasn't a bit surprised when my Navman 2100 fuel flow meter did not work correctly after I installed it. I re-read the installation instructions several times and moved the transducer to every possible position I could with the same results. I even replaced all the fuel lines from the tank to the fuel pump.

I finally sent the unit to Navman and they returned it. Unfortunately, they didn't share any info on it - whether they fixed it or just tested it and found it working correctly. When I finally got through to them and explained what the meter was doing, they said there must be some air in the system.

Like I said, I'm an idiot so I just gave up on it.

But when two mechanically minded friends of mine bought the same units and got the same results, I rethunk my problem.

In each of our installations, we have the transducer installed between the fuel/water separator and the fuel pump. The transducer is mounted so that the fuel flows upward (veritcally mounted) through the transducer on its way to the fuel pump. This is how Navman instructs to install.

The only thing I can think of that may be creating the problem we all three have - fuel consumption reads at 2 to 2.5 times actual consumption - is that we all three have our kicker motors plumbed off of the fuel/water separators. Would that create a problem?

Any advice will result in three happier fishermen. :D:D:D


Hey Phil,

I was wondering what type of engine you are running?
Reason I ask is I spoke with a floscan rep regarding there fuel management meter and they said there unit would not work with my 200 yami 4 stroke because of the duel fuel pump on the motor.
The rep said that I would get eronious readings like you mentioned.
Not sure if the one you got would work the same??
Anyway....
Good luck with your hook-up....

GaryB
Bay City
 

· Registered
Joined
·
3,137 Posts
Discussion Starter · #9 ·
Hey Phil,

I was wondering what type of engine you are running?
Reason I ask is I spoke with a floscan rep regarding there fuel management meter and they said there unit would not work with my 200 yami 4 stroke because of the duel fuel pump on the motor.
The rep said that I would get eronious readings like you mentioned.
Not sure if the one you got would work the same??
Anyway....
Good luck with your hook-up....

GaryB
Bay City
I've got a little 2.3 litre Ford with a single fuel pump. It should work with this engine....I think. :pray:
 

· Registered
Joined
·
3,137 Posts
Discussion Starter · #10 ·
I discovered the meter was set to liters! :shocked:

I'll be testing the accuracy of the unit this weekend. Thanks to LOL and GaryB for their help! :cheers:
 

· Registered
Joined
·
479 Posts
Man, no love and I was the guy that helped you figure it out!

Ouch!!!!

:flowered::flowered::flowered::flowered:

LA
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top